Les formules de calcul

 

Présentation générale

 La fonction =SOMME()
La fonction =SI()
La fonction =RECHERCHEV()

L’utilisation des outils
Comment nommer des cellules
Comment consolider (faire la synthèse) de plusieurs tableaux
Comment créer un graphique
Les tableaux croisés dynamiques
 

 

 Le classeur
Le ruban « Accueil »
Le ruban « Insertion »

 Les autres rubans

Les formules de calcul
La fonction =SOMME()
 
La fonction =SI()
La fonction =RECHERCHEV()

L’utilisation des outils
Comment nommer des cellules
Comment consolider (faire la synthèse) de plusieurs tableaux

 

La fonction =SOMME()

Pour additionner entre elles plusieurs cellules contiguës,

on peut utiliser la fonction SOMME d’EXCEL.

Ecrire dans la cellule où doit apparaître le résultat : =somme(

Sélectionner ensuite à la souris la plage de cellules à additionner.

Valider avec la touche Entrée

La fonction renvoie l’addition des sommes sélectionnées.

Exemple :  Dans la colonne A

12

-8

42

-15

 En A5

on écrit la formule suivante :

=SOMME(A1:A4) Le résultat donne : 31

La fonction =MOYENNE()

Pour obtenir la moyenne de plusieurs cellules contiguës,

on peut utiliser la fonction MOYENNE d’EXCEL.

Ecrire dans la cellule où doit apparaître le résultat : =moyenne(

Sélectionner ensuite à la souris la plage de cellules désirée

Valider avec la touche Entrée.

La fonction renvoie la moyenne des sommes sélectionnées

Exemple : Dans la colonne A

on a écrit des nombres. 28

12

32

16

20

48

On voudrait obtenir la moyenne des nombres de la colonne A.

En A7 on écrit la formule suivante :

=MOYENNE(A1:A6)Le résultat donne : 26

La fonction =SI()

On peut demander à Excel de réagir différemment en fonction du résultat d’un calcul demandé.

Exemple :

Vous décidez d’élaborer une facture.

Vous souhaitez faire bénéficier à votre client d’une remise sur le prix de vente.

Cette remise sera de 5% du total hors taxes de la facture si ce total inférieur à 1000 €.

Si le total hors taxes est supérieur ou égal à 1000 €, le taux de la remise sera de 10% sur la totalité du montant.

Le document Excel se présentera ainsi : 

 

La formule en D6, compare tout d’abord le résultat obtenu en D5 au nombre 1000.

Si le montant en D5 est plus petit que 1000, alors (symbolisé par le point virgule) le résultat à afficher en D6 sera celui du calcul : D5 multiplié par 5%.

Sinon (symbolisé par le deuxième point virgule) c’est à dire si le montant en D5 est égal ou plus grand que le nombre 1000, le résultat à afficher en D6 sera celui du calcul : D5 multiplié par 10 %

 

La fonction ET()

Les conditions posées dans le test de la fonction SI() seront multiples et pour que la réponse aux conditions soit « VRAI », il faudra quelles se vérifient toutes.

=SI(ET(Cond1;Cond2;…;CondN);action à réaliser si les N conditions sont satisfaites;action à réaliser si au moins une des conditions n’est pas satisfaite)

Exemple :

On désire attribuer une ristourne de fin d’année de 2% aux clients qui remplissent les 2 conditions suivantes : être grossiste ET avoir acheté plus de 100 000 € de marchandises chez nous.

Nos clients sont répertoriés dans le tableau ci-dessous.

 

A

B

C

1

Nom du client

Type de client

Achats

2

EMELINE

Grossiste

67 000 €

3

ACQUIN

Détaillant

138 000 €

4

HENDOL

Grossiste

213 000 €

5

JUNEZ

Détaillant

59 500 €

 On crée une colonne ristourne et on saisi dans cette colonne la formule suivante :

=SI(ET(type de client= »grossiste »;achats>100000);achats*2%;0)

Remarque :

Cette formule peut être recopiée sur les lignes suivantes.

On remarque que l’on utilise les nom des en-têtes de colonnes.

Cette technique fonctionne indépendamment des fonctions SI(), ET() et OU().

 

A

B

C

D

1

Nom du client

Type de client

Achats

Ristourne

2

EMELINE

Grossiste

67 000 €

0 €

3

ACQUIN

Détaillant

138 000 €

0 €

4

HENDOL

Grossiste

213 000 €

4 260 €

5

JUNEZ

Détaillant

59 500 €

0 €

 

La fonction OU()

Les conditions posées seront multiples et pour que la réponse aux conditions soit « VRAI », il faudra que l’une au moins se vérifie.

=SI(OU(Cond1;Cond2;…;CondN);action à réaliser si au moins une des conditions est satisfaite;action à réaliser si aucune des conditions n’est satisfaite) 

Exemple :

Une entreprise souhaite verser une prime de fin d’année à ses représentants s’ils remplissent l’une OU l’autre des conditions suivantes :

Avoir plus de 5 ans d’ancienneté

Avoir réalisé plus d’ 1 Million d’euros de chiffre d’affaires.

Les représentants sont répertoriés dans le tableau suivant :

 

A

B

C

1

Nom du Représentant

Années d’ancienneté

Chiffre d’affaires

2

ARMAND

3

1 213 000

3

FLORA

6

997 000

4

NINIAN

7

1 016 000

5

SEBATI

1

757 000

On crée une colonne PRIME et on y construit la formule suivante :

=SI(OU(années d’ancienneté>5;chiffre d’affaires>1000000);1000;0)

Remarque :

Cette formule peut être recopiée sur les lignes suivantes.

On remarque que l’on utilise les nom des en-têtes de colonnes.

Cette technique fonctionne indépendamment des fonctions SI(), ET() et OU().

 

A

B

C

D

1

Nom du Représentant

Années d’ancienneté

Chiffre d’affaires

Prime

2

ARMAND

3

1 213 000

0 €

3

FLORA

6

997 000

0 €

4

NINIAN

7

1 016 000

4 260 € 

5

SEBATI

1

757 000

0 €